Daily Archives: April 8, 2017

Ubuntu 14.04 with Grasehotspot 3.8 error because p2p1 network card name

Published by:

Menginstal grasehotspot yang merupakan software berbasis web untuk mengatur lalu lintas user internet berupa hotspot merupakan tantangan sendiri di Ubuntu 14.04. Dengan cpu dan motherboard keluaran terbaru. Seperti beberapa hari ini saya mencobanya di I5 + 8Gb DDr3 + motherboard (gigabyte mungkin) cukup memberikan pelajaran yang sangat bernilai.

Pertama, ubuntu 14.04 ternyata memberikan penamaan lan port yang sesuai dengan keberadaan port nya. Os ini tidak lagi menggunakan eth0 dan seterusnya, tapi dengan kode seperti p2p1 dan p3p1. Kira-kira demikian. Ketika masuk pada instalasi grasehotspot, maka barulah konfigurasi ini mengalami keanehan.

Yaitu program hotspot yang berjalan mulus di server, sekarang tidak jalan. Client tidak mendapatkan ip dari server. Ketika diperiksa di server, dengan perintah sudo ifconfig

Hasilnya ada urusan internet dengan p2p1 dan p3p1. Sebenarnya server internet berjalan, tapi device lain yang akan menggunakan grasehotspot, tidak jalan.

Salah satu solusinya adalah merubah penamaan p2p1 dsb tersebut kembali ke eth0 dan atau eth1.

Disini ada satu sumber bagaimana melakukannya : link

Langkah pertama yang disebutkan disana adalah mengubah parameter boot melalui grub.
Edit /etc/default/grub misalnya dengan vi atau nano editor

root@server:#nano /etc/default/grub

edit line dengan parameter di bawah dan isikan seperti tercantum

GRUB_CMDLINE_LINUX_DEFAULT=”net.ifnames=1 biosdevname=0″

Create if none and edit if any the /etc/udev/rules.d/70-persistent-rules
Find out the p2p1 and p3p1 mac address that we can find out with

root@server:#ifconfig

Now edit

root@server:#nano /etc/udev/rules.d/70-persistent-rules

Add these line

SUBSYSTEM==”net”, ACTION==”add”, ATTR{address}==”macadress”, NAME=”eth0″
SUBSYSTEM==”net”, ACTION==”add”, ATTR{address}==”macadress”, NAME=”eth1″

Dont’ forget to change the network configuration if static

root@server:#nano /etc/network/interfaces

Change any setting with p2p1 or p3p1 to eth0 and eth1. After that restart the computer.

It should be eth0 and eth1. So the grasehotspot should be running like mine.