Ubuntu Xenial – Libreoffice apt-get error

tutorials.ubuntu.com

OK, everything was start with the silly thing I ‘ve done. I deleted the libreoffice folder in opt then update it manually. I forgot that the earlier libreoffice I had was installed throug apt-get.

So when I tried to recover, or update dependencies to any software, I got these errors.

e-style-elementary 1:5.1.6~rc2-0ubuntu1~xenial8
 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
 Processing triggers for man-db (2.7.5-1) …
 Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) …
 Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) …
 Processing triggers for mime-support (3.59ubuntu1) …
 Processing triggers for shared-mime-info (1.5-2ubuntu0.2) …
 Processing triggers for hicolor-icon-theme (0.15-0ubuntu1.1) …
 Processing triggers for gnome-icon-theme (3.12.0-1ubuntu3) …
 Errors were encountered while processing:
  /var/cache/apt/archives/libreoffice-calc_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-gtk_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/python3-uno_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-base-core_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-math_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-style-galaxy_1%3a5.1.6~rc2-0ubuntu1~xenial10_all.deb
  /var/cache/apt/archives/libreoffice-style-elementary_1%3a5.1.6~rc2-0ubuntu1~xenial10_all.deb
  /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial10_all.deb
  /var/cache/apt/archives/libreoffice-writer_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-core_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-base-drivers_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-base_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-draw_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-impress_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-report-builder-bin_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-avmedia-backend-gstreamer_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-java-common_1%3a5.1.6~rc2-0ubuntu1~xenial10_all.deb
  /var/cache/apt/archives/libreoffice-sdbc-hsqldb_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
  /var/cache/apt/archives/libreoffice-pdfimport_1%3a5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
 E: Sub-process /usr/bin/dpkg returned an error code (1)

That was the tail part of the error.

I spent days to find out why. Until tonite I saw one line in the error.

 trying to overwrite '/usr/lib/libreoffice', which is also in package libreoffice-style-elementary 1:5.1.6~rc2-0ubuntu1~xenial8
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

I did that by executing the apt-get -f install process and put it into the logs. Anyway, I checked to /usr/lib the location of libreoffice. And it linked to /opt/libreoffice-6.2. So I got an idea. Delete the link and we’ll see.

So my hunch was right. The process was no longer error. The apt-get -f install finished successfully. Silly thing huh?

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.