Author Archives: admimin

fstab and how to edit it

Published by:

these all information i got from http://www.tuxfiles.org/linuxhelp/fstab.html written by nana langsted.
remind me of someone.
fstab is a configuration file that instruct the lilo on booting, to mount devices somewhere. so we can access that device when running linux. you can also learn about mount in www.tuxfiles.org
anyway this is how to edit it in simple words.

login as root and edit your fstab with
#nano /etc/fstab
or
#pico /etc/fstab

you will see one of this
example :
/dev/hda4 swap swap defaults 0 0
/dev/hda2 / ext2 defaults 1 1
/dev/hda1 /hda1 ntfs ro 1 0
/dev/hdb1 /home/original ntfs-3g defaults 0 0

the first column are the device that plugged in your cpu.
hda or hdb means your ide harddrive.
sda or sdb means your sata drive.
cdrom or dvdrom means your cd or dvd drive.
you can see these devices in /dev/ folder

the second column are the place that your mounting device located in your linux partition. you can edit all except the “/” and “swap” because these are you linux partition.

the third column are the type of your mounting device.
ext2 or ext3 means your linux. swap also.
vfat means fat32 or things like that. used by win 98-me-xp
ntfs means ntfs file system used by xp-vista. win 2000 uses “so 2000”

the fourth column are how these linux will be conducted.
defaults means your device will be conducted by linux system.
ro means read only
rw means read write. you can use rw on your other linux partition and vfat but not in ntfs. you need ntfs-3g to read and write.
auto noauto mean the devices will be mount automatically during startup. usually used for flash, floppy and etc.
user nouser mean normal user can mount the device or not. nouser is the defaults.
exec noexec mean your linux will run the binary or startup file on that device or not. dont use this command if you dont know what you’re doin.
sync async mean synchronously or not. used in floopy or flash.

the fifth columns is for define the dump option. whether the file system should be backup or not by fsck command. fsck is similar to chkdisk in windows. i think we are familiar with this.

the 6th columns is for for define the dump option. whether the file system should be check or not by fsck command.

that’s all. you can read it more in” tuxfiles.org”.

monitor resolution problem

Published by:

in the console mode or init 3 you can try this command  first

#xorgconfig

answer each questions appear on the screen. for the horizontal and vertical you may have to take a look to your monitor label. usually at the back of your monitor.  this is very important if the xorg doesnt configure it automatically. Especially in slackware. ubuntu can do this automatically

or you may try this command

#xorgsetup

it’s in gui mode. u have to fill all the questions appear.

but sometime those two command not work, so you have to take a look the xorg.conf manually.
still in init 3 mode, edit the xorg.conf

#nano /etc/X11/xorg.conf

see if the driver in device screen is the right driver. vesa is a universal driver but sometime it didnt work 100%. so if you have nvidia or ati graphic card, change the driver to nv or ati.  see the next line for configuration i have made

Driver “nv”
BusID “PCI:1:0:0”
VideoRam “128”

in the screen section make sure the device is the same with monitor section.
like “My Video Card” in screen section must be the same with monitor section device “My Video Card”

dont forget the default depth

DefaultDepth 24

save your xorg.conf

read write ntfs drive

Published by:

i got the information brom bayu blog wordpress

firts u should download the package ntfs-3g from the site http://www.ntfs-3g.org

then install the package

#installpkg ntfs-3g

clik Y when prompting

here is the step making the ntfs drive could be written by your linux

#mkdir /mnt/{winc,wind}

#ntfs-3g /dev/hdb0 /mnt/winc

#ntfs-3g /dev/hdb1 /mnt/wind

or

#mount -t ntfs-3g /dev/hdb0 /mnt/winc

#mount -t ntfs-3g /dev/hdb1 /mnt/wind

if you want your linux read the ntfs on booting type this in your /etc/fstab (at the end is ok)

/dev/hdb0 /mnt/winc ntfs-3g defaults 0 0

/dev/hdb1 /mnt/wind ntfs-3g defaults 0 0

check it out

problem connecting to internet in slackware because different host name

Published by:

i use two system in my comp. Vista and Slackware. and using d-links router as my internet gateway through my isp. i put a computer name in vista as sugi-pc and using static ip in my router. with hope that i would be connected faster.
but the problem came in my slackware. i put all the configuration in /etc/rc.d/rc.inet1.conf with the static ip and host name as sugi-slax. but using the same domain name: mskantor.
because i set the static ip inside my router with a vista host name, my linux wont come in to the router. coz using different host name. that ‘s why i cant ping my router ip.
so i configured back the rc.inet1.conf and activated the dhcp in eth0 and eth1. since that i use 2 lan card.
i emptied the ip address number become “” only then put the DHCP with “yes”
so i restart the slax and it took sometime when getting the ip from the router. but works fine.
i can use the internet again.

Network eth1 reconfigure

Published by:

i have two lan card on my pc. one is onboard and the other is on pci.
i use the pci since my onboard card seem stupidly not working.
so linux will identify them as eth0 and eth1.
so my pci lay on eth1 while the eth0 is for the onboard one.
in the installation procedure i already put the ip and mask address of my lan pc configuration. but the eth1 seems undetected.
when i went to kde, i try to reconfigure the network from the setting menu. but the eth0 or eth1 looked disable. i pressed the enable button, but nothing happen.
then i read again in the forum (i forgot the forum), i have to reconfigure the address by checking the ifconfig status

#ifconfig

and yes the eth1 not detected. only eth0 and lo configuration stated. so i need to configured manually the eth1.

#nano /etc/rc.d/rc.inet1.conf

the command is trying to write down manually the configuration of the eth1. so i wrote it down again the ip and the net. and check below the conf for the gateway. after all correct, i restart the inet.

#/etc/rc.d/rc.inet1 restart

then i have my network back. after i log in to kde, i turn on the network monitor so i can see whether the net is plugged of not. and yes it is plugged in. but the internet still not working. i dont know why. but i tried to reconfigure again all the step above. restart and activate the rc.inet1.conf and boom after restarting suddenly the internet worked.
but still i dont know what was really happen.

install ntfs-3g slackware 12.1

Published by:

i got the information brom bayu blog wordpress

firts u should download the package ntfs-3g from the site http://www.ntfs-3g.org

then install the package

#installpkg ntfs-3g

clik Y when prompting

here is the step making the ntfs drive could be written by your linux

#mkdir /mnt/{winc,wind}

#ntfs-3g /dev/hdb0 /mnt/winc

#ntfs-3g /dev/hdb1 /mnt/wind

or

#mount -t ntfs-3g /dev/hdb0 /mnt/winc

#mount -t ntfs-3g /dev/hdb1 /mnt/wind

if you want your linux read the ntfs on booting type this in your /etc/fstab (at the end is ok)

/dev/hdb0 /mnt/winc ntfs-3g defaults 0 0

/dev/hdb1 /mnt/wind ntfs-3g defaults 0 0

check it out

network eth1 reconfigure

Published by:

i have two lan card on my pc. one is onboard and the other is on pci.
i use the pci since my onboard card seem stupidly not working.
so linux will identify them as eth0 and eth1.
so my pci lay on eth1 while the eth0 is for the onboard one.
in the installation procedure i already put the ip and mask address of my lan pc configuration. but the eth1 seems undetected.
when i went to kde, i try to reconfigure the network from the setting menu. but the eth0 or eth1 looked disable. i pressed the enable button, but nothing happen.
then i read again in the forum (i forgot the forum), i have to reconfigure the address by checking the ifconfig status

#ifconfig

and yes the eth1 not detected. only eth0 and lo configuration stated. so i need to configured manually the eth1.

#nano /etc/rc.d/rc.inet1.conf

the command is trying to write down manually the configuration of the eth1. so i wrote it down again the ip and the net. and check below the conf for the gateway. after all correct, i restart the inet.

#/etc/rc.d/rc.inet1 restart

then i have my network back. after i log in to kde, i turn on the network monitor so i can see whether the net is plugged of not. and yes it is plugged in. but the internet still not working. i dont know why. but i tried to reconfigure again all the step above. restart and activate the rc.inet1.conf and boom after restarting suddenly the internet worked.
but still i dont know what was really happen.

install nvidia mx4000 geforce4 driver to slackware 12.1

Published by:

i got the nvidia driver package from www.nvidia.com for my nvidia geforce4 mx4000. i think nvidia gave me the same driver from several graphic models. the package called Nvidia-Linux-x86-96.43.05-pkg1.run
From the other site i got the info that run type file is a original group of file that still need to compile on linux. So I try to search other clue bout how to compile them. Then i found one in walecha site (this is the person who wrote the info). Here’re the clue i try to run:

# i put the Nvidia-Linux-x86-96.43.05-pkg1.run on my home folder /root/home
# make sure you log on as root and initlevel 3
#tar -xvzf Nvidia-Linux-x86-96.43.05-pkg1.run #unzip the package and produce Nvidia-xconfig folder
#./configure –opsi1 #didnt work, it was for knowing the script configuration
#make #making something i dont understand
#strip –strip-unneeded -v /usr/lib/*.so
#strip –strip-debug -v /usr/lib/*.a
#makepkg Nvidia-Linux-x86-96.43.05-pkg1.tgz
#installpkg Nvidia-Linux-x86-96.43.05-pkg1.tgz
#startx #to test the x-windows

but the test said nvidia driver not found. i dont know whats going on yet.

how to read password from windows mail export account

Published by:

hey i found something useful here. if you forget your email password that you filled in the windows mail accont, since that the password written in asterisk, u can go to http://www.motobit.com/util/iaf-password-recovery.asp.
but first u have to export the email account and ends up with iaf extention. then u go to the url.
and whala u reveal the password.
in this version u cannot read the user name account, only the first letter of your account revealed.
be satisfied, it’s free.

add ntfs directory to your fstab

Published by:

here are what i do
#mkdir /mnt/dataku #the directory where i m gonna put my access to windows
#mount /dev/hda5 /mnt/dataku
#nano /etc/fstab # edit the fstab, u may write this down
/dev/hda5 /mnt/dataku vfat defaults,user,umask=0 0 0 #user means all user can access. the type of window ntfs is vfat
#mount /dev/hda5 #re-mounting